SearchBuilder issues w/o ellispsis plugin

SearchBuilder issues w/o ellispsis plugin

crestATcrestAT Posts: 14Questions: 2Answers: 0

Back again with this issue, unfortunately with the latest release of Searchbuilder (1.0.1) - assuming to include the fix (as described here -> https://datatables.net/forums/discussion/65229/searchbuilder-error-on-empty-cells-in-a-column#latest ) - and Datatables (1.10.23) the problem with null data raised again. The only difference is that there is no longer an error displayed in the console, just -> No matching records found (column Office contains one null value)...

Added a test case here http://live.datatables.net/faqaqaxa/1/edit

Furthermore the use of the ellipsis plugin leads to a display of the escaped HTML string in the Value select box (maybe I missed somehing here from the docs...?),
eg Data => Position Condition => Equals than in the Value select one can see the escaped strings.

Another thing is to display and filter with a footer select 'all' special characters a user can input I struggle with a 'special' case where < and > are in one cell (for this I re-used the ellipsis plugin to escape the characters). Everything is working well (even cells with newline = \n inside but only the before mentioned case is not showing the correct result (selecting the Position footer select for Senior <Javascript> Developer -> No matching records found).
If you want me to raise a new thread for this please tell me...

Any hints to solve my issues are highly appreciated, many thanks in advance!

Replies

  • sandysandy Posts: 451Questions: 0Answers: 122

    Just spotted that you created a new issue for these, so will place my response here as well. We will track this here now rather than the old post.

    Hi @crestAT ,

    For null values I've reopened DD-1714 that colin raised previously, I'll take a look at it again at some point in the new year - I'm on holiday at the moment.

    The ellipsis plugin issue is also strange. I've raised an issue internally (DD-1789 for my reference) and will report back here when there is an update. I'll look at the other "special issue" as well as this in the new year at some point too.

    Thanks,
    Sandy

  • crestATcrestAT Posts: 14Questions: 2Answers: 0

    Hello Sandy!
    I created this new thread since I was not sure if the old one will be recognized since it contained already an accepted answer, sorry for this ...

    Thank you for taking care about these issues, have a nice holiday and best wishes for the New Year to you and all of the team!!!

    BR, Andreas

  • sandysandy Posts: 451Questions: 0Answers: 122

    Hi @crestAT ,

    Happy new year to you as well :)

    I've pushed a fix for the null values and also for the special html characters. You can access the fix from the nightly builds until the next release.

    For the issue with the ellipsis rendered values being used in SearchBuilder, I'd say that was expected behaviour as SearchBuilder uses the same values that are displayed to the user by default. The best thing to do to change it here would be to use columns.searchBuilder.orthogonal to manipulate what is displayed.

    I've updated your example to show all of the above working.

    Thanks,
    Sandy

  • crestATcrestAT Posts: 14Questions: 2Answers: 0

    Hi Sandy!

    Thanks a lot for the fix, will check you suggestion asap!

    Best regards,
    Andreas

  • crestATcrestAT Posts: 14Questions: 2Answers: 0

    Hello Sandy!

    Sorry for the delayed feedback ...

    Half way down :) ... the hint with columns.searchBuilder.orthogonal did the trick BUT on page reload (I added stateSave: true,) the Value select shows again ellipsized strings so the question would be - is there another orthogonal setting for page reload with saved state? Added the test case with stateSave here http://live.datatables.net/zopuyike/2/edit?html,css,js,output

    One issue with "special characters" is still evident, user data which contains < and > (in the test case -> column Position) there is Senior <Javascript> Developer for example - it's not possible to filter it with the footer filter neither with SearchBuilder ... not even with the standard datatables search.

    Thanks in advance!

    Best regards
    Andreas

  • colincolin Posts: 10,886Questions: 0Answers: 1,856

    Yep, I'm seeing that, thanks for the test case. We'll take a look and report back - it'll be probably Friday when Sandy is back,

    Colin

  • crestATcrestAT Posts: 14Questions: 2Answers: 0

    Thank you Colin!

  • sandysandy Posts: 451Questions: 0Answers: 122

    Hi @crestAT ,

    That should be the issue fixed now as you can see at this example (an updated version of your above test case). This fix will be available in the next SearchBuilder release. Until then you can access the fix from the nightly builds as before.

    Thanks,
    Sandy

  • crestATcrestAT Posts: 14Questions: 2Answers: 0

    Hello Sandy!
    Thanks a lot for the fast solution, will check it asap!
    Best regards

Sign In or Register to comment.