getting JS error after pagination navigation

getting JS error after pagination navigation

replix001replix001 Posts: 4Questions: 0Answers: 0

I load my datatable via ajax. Every thing is fine. I press one of the pagination links and I get an error when the data is returned:

Uncaught TypeError: settings.aoData[rowIdx] is undefined.

I am in the process of upgrading to from 1.10.20 to datatables 2.0.x. I do not get this error in the older version of datatables.

myNumbersDatatable = new DataTable('#myNumbers', {
responsive: true,
"processing": true,
"lengthMenu": [[100, 200, 300, 400], [100, 200, 300, 400]],
"serverSide": true,
"scrollY": "40vh",
"scrollCollapse": true,
"paging": true,
"info": true,
"searching": false,
"ajax": {
"url": "SystemFaxNumRequests.aspx?action=list_requests",
"data": buildSearchData,
"type": "POST"
},
"columns": [
{ "data": "", "class": "select-checkbox" },
{ "data": "id", "name": "id" },
{ "data": "form_id", "name": "form_id" },
{ "data": "realm", "name": "realm" },
{ "data": "create_time", "name": "create_time", render: DateRenderer },
{ "data": "status_text", "name": "status_text", render: StatusRenderer},
{ "data": "type_text", "name": "type_text", render: TypeRenderer },
{ "data": "assigned_faxnumber", "name": "assigned_faxnumber", render: FaxNumRenderer },
{ "data": "areacode1", "name": "areacode1", render: AreaCodeRenderer },
{ "data": "expected_carrier_completion", "name": "expected_carrier_completion", render: DateRenderer },
{ "data": "actions", "name": "actions", "defaultContent": "<i>Not set</i>", render: ActionRenderer }
],
"columnDefs": [
{
"targets": "hiddencol",
visible: false
},
{
orderable: false,
defaultContent: '',
className: 'select-checkbox',
targets: 0,
"width": "3%"
},
{
"targets": "nosort",
"orderable": false
}
],
select: {
style: 'os',
selector: 'td:first-child'
},
'order': [1, 'asc']
});

Replies

  • allanallan Posts: 62,246Questions: 1Answers: 10,211 Site admin

    Hi,

    If you are using DataTables 2.0.4, could you update to 2.0.5 please? It was released today and should correct this error.

    Allan

  • replix001replix001 Posts: 4Questions: 0Answers: 0

    Thanks! 2.0.5 fixed the issue.

Sign In or Register to comment.