Clear All button broken if initial table is empty

Clear All button broken if initial table is empty

kthorngrenkthorngren Posts: 16,098Questions: 25Answers: 3,811
edited January 2020 in SearchPanes

Not sure if this is a bug or maybe I'm missing something. My Datatable starts empty and shows the message No SearchPanes. The user selects an options which loads the table. I use the searchPanes.rebuildPane() to populate the search pane. But the Clear All button event doesn't fire. Here is the example:
http://live.datatables.net/foruzari/4/edit

Click the button to load the table to see the Clear All not working. Uncomment the ajax option to have initial data and the Clear All button works. Click the load button again and the Clear All button stops working.

Kevin

This question has accepted answers - jump to:

Answers

  • colincolin Posts: 14,303Questions: 1Answers: 2,430
    Answer ✓

    Yep, thanks for reporting, I've reproduced in our unit tests. I've raised it internally (DD-1346 for my reference) and we'll report back here when there's an update.

    Cheers,

    Colin

  • colincolin Posts: 14,303Questions: 1Answers: 2,430
    edited January 2020 Answer ✓

    Hi Kevin,

    This has been addressed. It'll be in the next release, but you can confirm the solution by using the nightly releases here.

    Cheers,

    Colin

  • kthorngrenkthorngren Posts: 16,098Questions: 25Answers: 3,811

    Great, thanks. I'll pickup the next version when available.

    Kevin

This discussion has been closed.