Using JSTL and Spring to Populate a DataTable then Export

Using JSTL and Spring to Populate a DataTable then Export

TykinTykin Posts: 1Questions: 0Answers: 0
edited February 2014 in TableTools
Hi there,
I am trying to use DataTables and TableTools to export a table I created using Spring Framework. The table works great, as does TableTools, with the exception of one pestering bug. When I am traversing an Array from Spring, the Copied and Exported values show up multiple columns later. Here is my code:


$(document).ready( function () {
var table = $('#example').DataTable({
"sDom": 'T<"clear">lfrtip',
"oTableTools": {
"sSwfPath": "swf/copy_csv_xls_pdf.swf",
"mColumns": "visible"
.on('mousedown', '.hasTooltip', function(event) {

hide: {
event: 'unfocus',
inactive: 2000,
effect: function() {
style: {
classes: 'qtip-bootstrap qtip-shadow'
overwrite: false,
content: {
text: $(this).next('div') // Use the "div" element next to this for the content
show: {
event: event.type,
ready: true
} );

Jobs with Failures





My problem is, when I go to export, the ${failrow} entries are multiple columns apart rather than being in the same cell. Strangely, this issue only occurs with FireFox and Chrome, but has no issue with IE. Unfortunately, I cannot post an example as the server is hosted internally.


  • mguttensohnmguttensohn Posts: 1Questions: 0Answers: 0
    Tykin, if I could help I would, but I am stuck trying to get my spring site to find the .swf file. Everything works great with data tables and even got the buttons and everything with table tools working. Only issue is that it cannot find and serve up the .swf so you cannot export. I am using Eclipse with a Jetty server for testing and have tried Netbeans with Glassfish. I am pulling my hair out. I have tried every possible way in every possible location to make this work, and cannot determine why I always get that the swf cannot be found.
This discussion has been closed.