deferRender in 1.10 is nuking TD attributes during render.

deferRender in 1.10 is nuking TD attributes during render.

nwanwa Posts: 1Questions: 0Answers: 0

I just upgraded our dataTables from 1.9.3 to 1.10.0 and seem to have encountered a bug. We have a number of tables where a custom attribute is set on each row which is then used towards custom 'features' and display attributes for certain rows. When deferRender is set to true those attributes are being eliminated. Our CSS classes are also being removed. Remove the property completely (presume default is false) then our functionality returns.

This worked fine in the 1.9.X branch. Anyone else experienced this?


  • canettascanettas Posts: 1Questions: 0Answers: 0

    We have experienced this as well
    Documentation of bDeferRender says that the property should be used for Ajax or js data sources, but I don't think it should break otherwise.
    (Maybe the correction is just set deferRender = false if no source is defined?)
    As you realized, this only occurs in 1.10.0 (in 1.9.x that worked)

    For developers analysis (hope it helps):
    v1.10.0 -
    v1.9.4 -

    I have tracked the difference from v1.9.4 (line 6779) to v1.10.0 (line 6287)
    where the function _fnGatherData was substituted by _fnAddTr
    In the older version the function kept the attributes from the table.

This discussion has been closed.