Filtering problem, please read for details

Filtering problem, please read for details

jlbriggsjlbriggs Posts: 15Questions: 2Answers: 1


I am having an issue that is hard to identify exactly.

Test case:

I have a table using DataTables, ColReorder, and ColVis, as well as individual column filtering.
I use this set up on dozens of tables throughout the site, all with no problems.

But this table is causing me endless trouble right now with the filtering.

As an example, click in the filter input for the 'Status' column. There are three statuses populated in the table: In Transit, Scheduled, and Hold.
Type scheduled or in transit into the filter box, and it filters correctly. Type 'hold' into the box, and there are no results.

As another example, click in the 'vendor' column filter, and type 'pace'.
Notice that
1) it filters based on the 'carrier' column, two columns to the right
2) it shows 4 rows after the filter. But unfiltered, there are actually 10 rows in that column with a value of 'pace'

One more: Container column. Type 'ymlu'. It filters down to one row, but there are several rows with that value.

I have run out of ideas for how to debug this. I am wondering if it is the content itself that is breaking something at this point...?

If anyone can provide tips, or point out something stupid that I've missed, I would be grateful.

This question has an accepted answers - jump to answer


  • SpoosieSpoosie Posts: 2Questions: 0Answers: 1


    i have exactly the same problem. Okay, with my own table, but it's the same issue!
    When i search in a specific column, i get the result for another col.

    I thought at first that it is because I hide the first columns, but after enable it.. the problem persists.

    Do you solved this?

    I use the actual version 1.10.1!

  • SpoosieSpoosie Posts: 2Questions: 0Answers: 1
    Answer ✓

    Okay, i've tried 1.10.2 nightly build, an what should i say.. it works!

  • jlbriggsjlbriggs Posts: 15Questions: 2Answers: 1

    1.10.2 solves my problem as well.

    This in particular was probably the culprit:

    "Fix: Regression from 1.10 whereby empty data for a column could cause an offset in the filtering column"

    From the commit notes here:

This discussion has been closed.