keyTable navigation does not work while filtering dataTables(if searching input is not empty)

keyTable navigation does not work while filtering dataTables(if searching input is not empty)

tokitoki Posts: 2Questions: 0Answers: 0

It seems that there is a problem with working keyTable navigation with arrows if dataTables searching input is not empty(while dataTables is filtered). IS it possible to solve this problem ?

Replies

  • usmanarfaniusmanarfani Posts: 6Questions: 1Answers: 0

    I am having the same issue and it looks like author does not have the solution for it. right?

  • allanallan Posts: 48,301Questions: 1Answers: 6,970 Site admin

    This should be resolved in the nightly version of KeyTable. Could you try that and let me know how you get on with it? If it still down't work, can you give me a link to a page showing the issue (that is using the nightly version).

    I expect to release the updated version of KeyTable with this fix next week.

    Allan

  • usmanarfaniusmanarfani Posts: 6Questions: 1Answers: 0

    yes allan, now it's working perfectly :) thank you so much.....but what about if i have fixed columns too. Keytable is working on one table but not working on fixed column table. Please help me with this too

  • allanallan Posts: 48,301Questions: 1Answers: 6,970 Site admin

    Sorry - but KeyTable and FixedColumns are not currently compatible to allow focus in the fixed columns. This is noted in the compatibility table.

    Allan

  • usmanarfaniusmanarfani Posts: 6Questions: 1Answers: 0

    but Allan it should be i mean this is a scenario anyone would have to face. Anyone who is using fixed column with key table would face this issue don't you think there should be solution for this?

  • allanallan Posts: 48,301Questions: 1Answers: 6,970 Site admin

    Yes I agree there should be. Unfortunately I haven't had time to develop it yet. The code is open source and you are welcome to contribute a fix if you would like.

    Allan

  • tokitoki Posts: 2Questions: 0Answers: 0

    Hi Allan,

    I am just tried keytable new version. It is working perfectly now. I am sorry that I am too late to let you know. Thank you very much. Toki

This discussion has been closed.