pdf button disappeared

pdf button disappeared

vimasoftvimasoft Posts: 2Questions: 1Answers: 0

{extend: 'pdf', text: 'PDF'}

my pdf button isnt showing up anymore. Unfortunatley I cannot say when (after which update) it happened. Every other export button (csv, excel, ...) is still visible!
I already tried the following:

  • changing 'pdf' to 'pdfHtml5'
  • upgrading to Datatables 1.10.13 and Buttons 1.2.4
  • switching declaration order of all files (dataTables.buttons.min.js, pdfmake.min.js, vfs_fonts.js, jszip.min.js, buttons.html5.min.js, ...) ---> by the way: which order is the right one?

nothing brought back my pdf button :/

Any suggestion or is this behaviour already known?

This question has an accepted answers - jump to answer


  • kthorngrenkthorngren Posts: 18,570Questions: 26Answers: 4,406
    edited February 2017 Answer ✓

    In a basic config that combination of versions works. Do you see any console messages?

    Maybe you can post your code or a link showing the issue.

    Take a look at one of the examples to see a working declaration order.

    if pdfmake.min.js and vfs_fonts.js don't load the PDF button won't show while the others will.


  • vimasoftvimasoft Posts: 2Questions: 1Answers: 0

    thanks for your answer, Kevin!

    It is working again! You were right and the vfs_fonts.js didnt load because of the permissions of this file :| . After I granted access everything worked again!

This discussion has been closed.