Autofill drop error after edit cell

Autofill drop error after edit cell

urbanjurbanj Posts: 20Questions: 4Answers: 0

Dear Alan!
The datatables autofill drop error when i begin select edited cell. (mouse down in small blue rectangle)
If I step another cell with right arrow key, and step back left arrow key, (the edited cell is active, but not editing) the select is good and autofill is runing.
Uncaught TypeError: Cannot read property 'offsetParent' of undefined
at AutoFill._getPosition (dataTables.autoFill.js:606)
at AutoFill._drawSelection (dataTables.autoFill.js:397)
at AutoFill._mousedown (dataTables.autoFill.js:662)
at HTMLDivElement.<anonymous> (dataTables.autoFill.js:170)
at HTMLDivElement.dispatch (jquery-latest.js:1549)
at HTMLDivElement.r.handle (jquery-latest.js:1489)

the error is _getPosition: function, currOffsetParent = $( currNode[0].offsetParent ); line, because the currNode will emty object after parrent is nothing.
You use back tested cycle:
currOffsetParent = $( currNode[0].offsetParent )
currNode = currOffsetParent;
} while ( currOffsetParent.get(0) !== targetParent.get(0))

This run when currOffsetParent.get(0) !== targetParent.get(0) because You set currNode the parentNode, and the parrentNode nothing, the next cycle run will drop this error.
I use editor, scroller, button, selector, keytable, fixed column and autofill, and I use server side, and not use pager.
And the second problem:
After the autofill is runing, (no error, and selected cell is replaced) the selected cell box is active and drop same error, wheni not change to another column.

If i change another column the select is will good, the previously selected box is nothig, and no drop error.

Any idea? (I use too many extension, and they will problem?)
I not can make sample program, because i use server side select own php , and i use mysql 8 json field to store data.


  • allanallan Posts: 49,585Questions: 1Answers: 7,309 Site admin

    Could you give me a link to a page showing the issue please? It appears to work in this example.


  • urbanjurbanj Posts: 20Questions: 4Answers: 0
    edited October 2018

    Dear Allan!
    I make test website for you.
    You need login:

    If You logged in, then change this:

    Or select Projekt Teszt, and click Test table
    The icons not working, but You can change field, and You can select field, and can test autofill.
    Please check this page, and help Me, because I dont understand why it dont work. What have I done wrong?

  • allanallan Posts: 49,585Questions: 1Answers: 7,309 Site admin

    Thanks for the link. I've just tried it with the "Test1" column and it appeared to work okay. The cells were written with a value of "2" and no error was reported.

    What browser and OS are you using?

    Does the example that I linked to above work for you?


  • urbanjurbanj Posts: 20Questions: 4Answers: 0

    Dear Allan!
    I use
    Google Chrome
    Version: 69.0.3497.100 (64 bites)
    Windows 10 pro (Hungarian)
    I check non Hungarian version windows 10, but error is same, and your samle is runing this broser, and this windows version.
    I make same screen shots:
    I change row 3 Test2 column

    I click small blue rectangle and pull down

    I release left button

    I see, the chgange text is only 1 cell, because i down mose left button and hold, the selected rectangle drawed (I not pull, ony hold left button down)

    I pull down when button is downed, the normal windows selection begin, and i release the button, the new area will fill last row value (but i not see new selected area box, because the java is dropped error)

    If I entered row 3 Test2 column and change value hit enter and change column and I will back row 3 Test2 on arrow key (not mouse click, because if I click in cell, cell will edited, and error will again) and pull down blue rectangle, the autofill is working

    but i click again the small blue rectangle and hold down left mouse button, the previously selected area is drawed, and java drop 'offsetParrent' of undefiined error.

    What browser and OS are you using? (But your example is working, but your example not use, sroller, use pager, not use server, side....)

    Please try ,my above example.

  • urbanjurbanj Posts: 20Questions: 4Answers: 0

    Dear Allan!
    Can You testing my example?

  • allanallan Posts: 49,585Questions: 1Answers: 7,309 Site admin


    I wasn't able to reply over the weekend, sorry.

    Yes indeed I can see the issue now with your instructions. Unfortunately I'm not immediately sure what is causing the problem. I'll need to dig into this and get back to you as I can reproduce it in my test cases.


Sign In or Register to comment.