record disappear after key in words at filter

record disappear after key in words at filter

cokechiucokechiu Posts: 40Questions: 14Answers: 5

Hi,

URL: http://anta.dige2.net/admin/
Username: datatables
Password: 12345678

Left menu -> Collection

Description of the problem:
- There is with category name [ Mutina ] and name [ COVER ]
- Default ordering on tables are id 0 ASC, 1 ASC
- The record with name [COVER] not shown in the table
- When I change to order by category only, the record appears again ( at page 3 )
- Type [ cover ] at search box has no result.

Would you please help ?

This question has accepted answers - jump to:

Answers

  • colincolin Posts: 9,834Questions: 0Answers: 1,632

    Hi @cokechiu ,

    The login isn't working - would you be able to paste the code live.datatables.net?

    Cheers,

    Colin

  • cokechiucokechiu Posts: 40Questions: 14Answers: 5
    edited July 2019

    Hi,

    I am sorry, the page login information list as below

    Username: dige2
    Password: 95593913

    The admin page login information list as below

    Username: datatables
    Password: 12345678

  • allanallan Posts: 52,715Questions: 1Answers: 8,069 Site admin

    How odd! Could you update to the latest DataTables as the first step please? You are currently using 1.10.15.

    Thanks,
    Allan

  • cokechiucokechiu Posts: 40Questions: 14Answers: 5

    Dear Allan,

    Ok, let me update first. Thanks

  • cokechiucokechiu Posts: 40Questions: 14Answers: 5

    I have update all libaries.

    The url changed to: http://anta.dige2.net/admin/test.php

    URL: http://anta.dige2.net/admin/test.php
    Username: datatables
    Password: 12345678

    Left menu -> Collection

    Description of the problem:
    - There is with category name [ Mutina ] and name [ COVER ]
    - Default ordering on tables are id 0 ASC, 1 ASC
    - The record with name [COVER] not shown in the table
    - When I change to order by category only, the record appears again ( at page 3 )
    - Type [ cover ] at search box has no result.

    Would you please help ?

  • allanallan Posts: 52,715Questions: 1Answers: 8,069 Site admin

    Hi,

    I'm getting a 404 from http://anta.dige2.net/admin/test.php I'm afraid.

    Allan

  • cokechiucokechiu Posts: 40Questions: 14Answers: 5
  • allanallan Posts: 52,715Questions: 1Answers: 8,069 Site admin

    I'm completely unsure why this isn't working I'm afraid! Could you change https://cdn.datatables.net/1.10.19/js/jquery.dataTables.min.js to be https://cdn.datatables.net/1.10.19/js/jquery.dataTables.js (i.e. the non-min version) and I'll trace it through the DataTables code to see what is going wrong.

    Thanks,
    Allan

  • cokechiucokechiu Posts: 40Questions: 14Answers: 5

    Hi,

    Changed, thanks for helping me.

  • allanallan Posts: 52,715Questions: 1Answers: 8,069 Site admin
    Answer ✓

    There is a UTF8 character e2 80 a8 (in hex) at the start of the string 
The collection consists of unglazed porcelain stoneware body (UGL) in the description of the Cover row. That's causing the regex test on that row to fail for some reason.

    It appears that is a UTF8 line separator (U+2028, LINE SEPARATOR) and Javascript doesn't like that (indeed, DataTables actually strips out new line character for that reason on filtering).

    I'm just looking into making that change in DataTables and will post back soon.

    Thanks,
    Allan

  • allanallan Posts: 52,715Questions: 1Answers: 8,069 Site admin
    Answer ✓

    I've just committed a change for this and the nightly will carry the change shortly.

    Regards,
    Allan

  • cokechiucokechiu Posts: 40Questions: 14Answers: 5

    Thanks, Allan.

Sign In or Register to comment.