Fatal Error when validating input

Fatal Error when validating input

th3t1ckth3t1ck Posts: 190Questions: 31Answers: 1

I'm using editor 1.9.1 and when I try to add an entry to the database the "Validate::dbValues" throws the following error.

Fatal error:  Uncaught Error: Call to undefined function DataTables\Editor\mb_strlen() in /var/www/html/php/Editor/Validate.php:635
Stack trace:
#0 [internal function]: DataTables\Editor\Validate::DataTables\Editor\{closure}('T23456', Array, Object(DataTables\Editor\Field), Array)
#1 /var/www/html/php/Editor/Field.php(674): call_user_func(Object(Closure), 'T23456', Array, Object(DataTables\Editor\Field), Array)
#2 /var/www/html/php/Editor.php(814): DataTables\Editor\Field->validate(Array, Object(DataTables\Editor), '0')
#3 /var/www/html/php/Editor.php(996): DataTables\Editor->validate(Array, Array)
#4 /var/www/html/php/Editor.php(683): DataTables\Editor->_process(Array)
#5 /var/www/html/users-con.php(61): DataTables\Editor->process(Array)
#6 {main}
  thrown in /var/www/html/php/Editor/Validate.php on line 635

If I comment out "Validate::dbValues" editor works fine and adds the entry to the table. Any ideas?

This question has an accepted answers - jump to answer

Answers

  • th3t1ckth3t1ck Posts: 190Questions: 31Answers: 1

    Also here is my PHP version.

  • allanallan Posts: 52,661Questions: 1Answers: 8,058 Site admin
    Answer ✓

    Hi,

    This happens when multibyte string support functions are disabled in PHP. Or at least it happened in the Editor 1.9.0 PHP libraries. It was fixed for 1.9.1 with 1.9.2 being the current release.

    It might be that you are using 1.9.1 Javascript, but 19.0 of the PHP libraries? It would be worth updating the PHP libs as I think they should resolve this issue.

    Allan

  • th3t1ckth3t1ck Posts: 190Questions: 31Answers: 1

    Ahhh, I'll bet you're right. I'll take a peek.

  • th3t1ckth3t1ck Posts: 190Questions: 31Answers: 1

    You're right Allan. I forgot to change out the libraries. I also downloaded 1.9.2 yesterday hoping it was a bug and it would resolve my problem, but I forgot the libraries.

    Thank you again for your prompt help.

Sign In or Register to comment.