Upgrade from DT 1.13.5 to 2.0.3 leads to errors in Wordpress set up

Upgrade from DT 1.13.5 to 2.0.3 leads to errors in Wordpress set up

BjornHaBjornHa Posts: 34Questions: 5Answers: 0

Using Editor 2.3.2.

Debug code is: esejux

Erros encountered in console:

JQMIGRATE: Migrate is installed, version 3.4.1

dataTables.editor.min.js:6 Uncaught TypeError: Cannot read properties of undefined (reading '_fnExtend')
at dataTables.editor.min.js:6:2833
at dataTables.editor.min.js:6:416
at dataTables.editor.min.js:6:442
(anonymous) @ dataTables.editor.min.js:6
(anonymous) @ dataTables.editor.min.js:6
(anonymous) @ dataTables.editor.min.js:6

editor.bootstrap5.min.js:4 Uncaught TypeError: Cannot read properties of undefined (reading 'defaults')
at editor.bootstrap5.min.js:4:597
at editor.bootstrap5.min.js:4:509
at editor.bootstrap5.min.js:4:535
(anonymous) @ editor.bootstrap5.min.js:4
(anonymous) @ editor.bootstrap5.min.js:4
(anonymous) @ editor.bootstrap5.min.js:4

jquery.min.js?ver=3.7.1:2 jQuery.Deferred exception: $.fn.dataTable.Editor is not a constructor TypeError: $.fn.dataTable.Editor is not a constructor
at HTMLDocument.<anonymous> (https://testwpadmin.pro4u.se/tidrapporter:551:21)
at e (https://testwpadmin-cdn.pro4u.se/wp-includes/js/jquery/jquery.min.js?ver=3.7.1:2:27028)
at t (https://testwpadmin-cdn.pro4u.se/wp-includes/js/jquery/jquery.min.js?ver=3.7.1:2:27330) undefined
ce.Deferred.exceptionHook @ jquery.min.js?ver=3.7.1:2
t @ jquery.min.js?ver=3.7.1:2
setTimeout (async)
(anonymous) @ jquery.min.js?ver=3.7.1:2
c @ jquery.min.js?ver=3.7.1:2
fireWith @ jquery.min.js?ver=3.7.1:2
fire @ jquery.min.js?ver=3.7.1:2
c @ jquery.min.js?ver=3.7.1:2
fireWith @ jquery.min.js?ver=3.7.1:2
ready @ jquery.min.js?ver=3.7.1:2
P @ jquery.min.js?ver=3.7.1:2

jquery.min.js?ver=3.7.1:2 Uncaught TypeError: $.fn.dataTable.Editor is not a constructor
at HTMLDocument.<anonymous> (tidrapporter:551:21)
at e (jquery.min.js?ver=3.7.1:2:27028)

at t (jquery.min.js?ver=3.7.1:2:27330)

CDN calls working:
<link href="https://cdn.datatables.net/v/bs5/jszip-3.10.1/dt-1.13.5/b-2.4.1/b-colvis-2.4.1/b-html5-2.4.1/b-print-2.4.1/date-1.5.1/fc-4.3.0/kt-2.10.0/rg-1.4.0/sc-2.2.0/sl-1.7.0/datatables.min.css" rel="stylesheet">

Failing:
<link href="https://cdn.datatables.net/v/bs5/jszip-3.10.1/dt-2.0.3/b-3.0.1/b-colvis-3.0.1/b-html5-3.0.1/b-print-3.0.1/date-1.5.2/fc-5.0.0/kt-2.12.0/rg-1.5.0/sc-2.4.1/sl-2.0.0/datatables.min.css" rel="stylesheet">

Must have missed something..

Replies

  • BjornHaBjornHa Posts: 34Questions: 5Answers: 0

    Font changes in text because I used a separator to enclode error text that must have triggered something...

  • allanallan Posts: 61,970Questions: 1Answers: 10,160 Site admin

    It sounds like you've updated your DataTables version, but not Editor. The version of Editor you have is using a private API method which is no longer available in DT2. Updating to Editor 2.3 or newer will address that.

    Allan

  • BjornHaBjornHa Posts: 34Questions: 5Answers: 0

    Editor installed according to DataTalbes debugger was 2.3.2, thats why I opened the discussion.
    However, it must have been a cache issue, no error today.
    Thought I flushed all caches on my way, but apparently not.
    Thanks for quick response.

  • allanallan Posts: 61,970Questions: 1Answers: 10,160 Site admin

    No worries - thanks for the update. Good to hear it is working now.

    Allan

Sign In or Register to comment.