When do I need to include keyTable.bootstrap4.min.js file ?

When do I need to include keyTable.bootstrap4.min.js file ?

ronald.woutersronald.wouters Posts: 9Questions: 4Answers: 0
edited May 2019 in KeyTable

Hi all,

when you look at the keytable bootstrap styling page and you look at the "Javascript library files loaded for use in this example" you will notice that only dataTables.keyTable.min.js is mentioned.

In the KeyTable-2.5.0 download package there is also a file keyTable.bootstrap4.min.js present.
This file is not used by the example mentioned above.

So my question is obvious: when do I need to use the keyTable.bootstrap4.min.js file ?

Regards,
Ronald Wouters

Replies

  • colincolin Posts: 9,177Questions: 0Answers: 1,533

    Hi @ronald.wouters ,

    That's only present as the whole KeyTable package is also downloaded - if you uncheck "Concatenate" you'll see the individual files that you need. The list of files on the page you referenced is all that you need,

    Cheers,

    Colin

  • ronald.woutersronald.wouters Posts: 9Questions: 4Answers: 0

    Ok, so if I understand correctly, I do not need that keyTable.bootstrap4.min.js probably because on the page I referenced, dataTables.bootstrap.min.js is mentioned which is for Bootstrap 3 integration I think. Is that correct ?

    However, I am using Bootstrap 4.
    So, in that case, do I need to add keyTable.bootstrap4.min.js or does it completely replace dataTables.keyTable.min.js ?

  • kthorngrenkthorngren Posts: 9,769Questions: 25Answers: 2,255

    This doc discusses what is needed for Bootstrap4 integration.
    https://datatables.net/manual/styling/bootstrap4

    It suggests that you would need something like keyTable.bootstrap4.min.js. However if you follow Colin's suggestion and use the Download Builder it doesn't have that file. So it would seem that in this case there is no keyTable.bootstrap4.min.js to use.

    Kevin

  • allanallan Posts: 52,268Questions: 1Answers: 7,959 Site admin

    I think the confusion here is KeyTable specific - it doesn't need a Javascript file for its Bootstrap 4 integration.

    It is available to keep package managers happy (many don't like a style only package), but if you have a look at the file it doesn't actually do anything!

    Allan

This discussion has been closed.