Filter selections get de-selected when multi-selections are made on same column

Filter selections get de-selected when multi-selections are made on same column

JohnRWJohnRW Posts: 5Questions: 1Answers: 0

Description of problem:
I have 2 filterable columns in my table, (category and status). If I select a category and a status to filter on then select a second status the category gets de-selected.

This question has an accepted answers - jump to answer

Answers

  • kthorngrenkthorngren Posts: 14,171Questions: 25Answers: 3,343

    That behavior doesn't happen with this example. Please provide a link to your page or a test case replicating the issue so we can help debug.
    https://datatables.net/manual/tech-notes/10#How-to-provide-a-test-case

    Kevin

  • JohnRWJohnRW Posts: 5Questions: 1Answers: 0

    http://live.datatables.net/cawovefu/1/edit

    Under Position search Data Coordinator
    Under Office search Edinburgh
    Now add London

    When London is added the first selection is de-selected

  • colincolin Posts: 12,939Questions: 0Answers: 2,204
    Answer ✓

    It looks like that's an old issue that's been addressed. I've updated your example with the most recent releases (using the download page) and everything appears to be behaving as expected. Could you take a look and see if that works for you, please,

    Colin

  • JohnRWJohnRW Posts: 5Questions: 1Answers: 0

    Thanks very much Colin. Just one question, you replaced a bunch of file references with just 2, are there single files (js & css) which incorporate all the features?

  • colincolin Posts: 12,939Questions: 0Answers: 2,204

    That's right. With the download page, you can either concatenate the files (as I did with that URL), or you can have them all separate. It's slightly more efficient to have them in one file (less downloads),

    Colin

  • JohnRWJohnRW Posts: 5Questions: 1Answers: 0

    Thanks again Colin, just one issue I am still having. When I initially open the filter button each filter box spans the entire screen and display one under the other. If I open the web development tools each box reverts to normal size making it hard to find the issue. Any suggestions?

  • JohnRWJohnRW Posts: 5Questions: 1Answers: 0

    Issue has been solved, thanks

Sign In or Register to comment.