Misspelled and faulty Composer packages [-ju vs. -jqui] (jQuery UI-Styling)

Misspelled and faulty Composer packages [-ju vs. -jqui] (jQuery UI-Styling)

contigo_mrcontigo_mr Posts: 1Questions: 1Answers: 0

I'm trying to switch from manually downloaded packages to an composer-installation.
I need to install DataTables + jQuery UI with the jQuery UI styling framework and available extensions.

But it seems like the package-names on the downloads-page in the composer-tab are not equal to the ones listed on your packagist. Additionally the dependency-references on packagist itself are not not correct I guess.

For example:
DataTable - Buttons (w. jQuery UI Styling):
... I havent fully checked all the other packages/extensions, but Im pretty sure this is might be a issue in general.

On your download-page it sais: "datatables.net-buttons-jqui"
On packagist the package is called "datatables.net-buttons-ju"
... but the requirements still say "datatables.net/datatables.net-jqui", which is a nonexistant package

So I cannot properly install jQuery UI DataTable because of the misspelled names throughout your requirements.

I hope the issue is quite clear - not a native speaker here :)

Screenshots from your website/packagist:

Console-Output on "composer require ...":

> composer require datatables.net/datatables.net-butons-ju
Could not find package datatables.net/datatables.net-butons-ju.
Pick one of these or leave empty to abort:
  [0] datatables.net/datatables.net-buttons-ju
> 0
./composer.json has been updated
Running composer update datatables.net/datatables.net-buttons-ju
Loading composer repositories with package information
Updating dependencies
Your requirements could not be resolved to an installable set of packages.

  Problem 1
    - Root composer.json requires datatables.net/datatables.net-buttons-ju * -> satisfiable by datatables.net/datatables.net-buttons-ju[3.0.0, 3.0.1, 3.0.2].
    - datatables.net/datatables.net-buttons-ju[3.0.0, ..., 3.0.2] require datatables.net/datatables.net-jqui >=1.12.1 -> could not be found in any version, there may be a typo in the package name.

Potential causes:
 - A typo in the package name
 - The package is not available in a stable-enough version according to your minimum-stability setting
   see <https://getcomposer.org/doc/04-schema.md#minimum-stability> for more details.
 - It's a private package and you forgot to add a custom repository to find it

Read <https://getcomposer.org/doc/articles/troubleshooting.md> for further common problems.
You can also try re-running composer require with an explicit version constraint, e.g. "composer require datatables.net/datatables.net-butons-ju:*" to figure out if any version is installable, or "composer require datatables.net/datatables.net-butons-ju:^2.1" if you know which you need.

Installation failed, reverting ./composer.json and ./composer.lock to their original content.
PS C:\xampp\xampp8\htdocs\conni\php\contigoutils\composer>
Sign In or Register to comment.